Bandwidth Video Conference Zoom

Category : Network | Sub Category : Mikrotik Posted on 2020-10-14 20:55:44


Bandwidth Video Conference Zoom

Pertemuan secara daring melalui video conference menjadi sangat penting, seiring dengan dunia yang saat ini tengah beradaptasi dengan tatanan normal baru (new normal) imbas pandemi Covid-19. Hal ini dipilih karena video conference dinilai sebagai cara yang aman, nyaman, dan gratis untuk tetap terhubung, untuk kepentingan bisnis maupun bersosialisasi.

Ada berbagai media yang digunakan untuk melaksanakan meeting atau video conference, salah satu yang banyak digunakan adalah Zoom Meeting. Pada artikel kali ini kami akan mencoba mengoptimalkan jaringan dengan memprioritaskan koneksi yang digunakan video conference agar bisa digunakan dengan baik tanpa ada gangguan. Bandwidth yang digunakan akan diprioritaskan agar tidak terganggu saat client lain browsing ke internet.

Sebelumnya, kita coba cari terlebih dahulu semua informasi mengenai aplikasi Zoom, baik dari ip server, protokol dan port yang digunakan. Informasi dari website resmi Zoom, aplikasi Zoom menggunakan protocol TCP dan UDP dengan port 80, 443, 3478, 3479, 5090, 5091, 8801-8810. Protokol dan port tersebut yang akan kita gunakan untuk menangkap traffic menuju server Zoom. Selain protocol dan port, bisa juga berdasarkan IP server Zoom yang akan kita tambahkan ke dalam router.

Address Lists

Untuk langkah pertama, tambahkan List IP server Zoom pada Firewall>Address-Lists router. Agar lebih mudah, silahkan cek list ip server zoom disini : zoom-ip
Copy script zoom-ip tersebut dan masukkan kedalam router dengan membuka New Terminal lalu klik-kanan Paste.

Jika sudah berhasil, cek ulang pada menu IP>Firewall>Address Lists apakah IP Zoom sudah tertambahkan secara otomatis. Akan ada list IP server Zoom dengan nama "zoom_ip".

Perlu diketahui, tidak semua IP yang digunakan oleh server Zoom ada pada script tersebut. Untuk menambahkan secara otomatis, tambahkan rule mangle berdasarkan port yang digunakan oleh aplikasi zoom.

Tambahkan dua rule untuk TCP dan UDP dengan destination port yaitu port 3478, 3479, 5090, 5091, 8801-8810 (selain 80 dan 443).

Berikut command yang digunakan :

 /ip firewall mangle

add chain=prerouting dst-address-list=!zoom_ip dst-port=3478,3479,5090,5091,8801-8810 protocol=tcp action=add-dst-to-address-list address-list=zoom_ip;

add chain=prerouting dst-address-list=!zoom_ip dst-port=3478,3479,5090,5091,8801-8810 protocol=udp action=add-dst-to-address-list address-list=zoom_ip;


Jika menggunakan winbox konfigurasinya seperti berikut

Kedua rule diatas digunakan untuk menambahkan IP baru yang belum terdaftar pada Address-Lists. Nama Address-Lists-nya dibuat sama dengan list import yaitu "zoom_ip" dan akan terupdate otomatis jika ada koneksi baru Zoom.

Mangle

Langkah selanjutnya, untuk menangkap traffic koneksi aplikasi Zoom, tambahkan rule baru pada mangle dengan action mark-connection. Protocol port diisi port yang digunakan oleh zoom yaitu Protocol TCP dan UDP dengan Port 3478, 3479, 5090, 5091, 8801-8810. Beri nama koneksi yang sudah ditangkap, contoh "koneksi_zoom".

Berikut command yang digunakan.

/ip firewall mangle

add chain=prerouting protocol=tcp dst-port=3478,3479,5090,5091,8801-8810 action=mark-connection new-connection-mark=koneksi_zoom passthrough=yes;

add chain=prerouting protocol=udp dst-port=3478,3479,5090,5091,8801-8810 action=mark-connection new-connection-mark=koneksi_zoom passthrough=yes;


Jika menggunakan winbox konfigurasinya adalah sebagai berikut :



Selain port 3478, 3479, 5090, 5091, 8801-8810, aplikasi Zoom juga menggunakan protokol TCP 80 dan TCP 443. Tambahkan rule baru dengan dst-port=80,443 dan Dst. Address List = zoom_ip yang sudah ditambahkan tadi.

Berikut command yang digunakan :

 /ip firewall mangle add chain=prerouting protocol=tcp dst-port=80,443 dst-address-list=zoom_ip action=mark-connection new-connection-mark=koneksi_zoom passthrough=yes

Jika menggunakan winbox konfigurasinya adalah sebagai berikut :


Rule diatas digunakan untuk menangkap traffic zoom yang menggunakan protocol tcp port 80,443. Terdapat tambahan dst-address-list=zoom-ip agar paket browsing lain tidak tertangkap oleh rule ini. Pastikan nama mark-connection sama dengan rule sebelumnya (koneksi_zoom).

Setelah koneksi tertangkap, ada satu rule lagi yang harus ditambahkan yaitu mark-packet. Tambahkan rule baru dengan Action Mark Packet beri nama baru, misal packet_zoom. Pastikan connection mark diisi mark-connection = koneksi_zoom yang sudah dibuat tadi.Packet-mark ini yang akan kita gunakan untuk bandwidth management, baik pada menu simple queue atau pada queue tree.

Berikut command yang digunakan :
/ip firewall mangle
add chain=forward action=mark-packet connection-mark=koneksi_zoom new-packet-mark=paket_zoom passthrough=no



Hasilnya akan terdapat beberapa rule pada mangle seperti berikut



Bandwidth Management
Setelah mark-packet ditambahkan pada mangle, coba gunakan aplikasi zoom dan lihat counters pada mangle untuk mengecek apakah rule sudah berjalan dengan benar.

Dari packet-mark "paket_zoom" kita bisa gunakan untuk limitasi bandwidth pada simple queue atau queue tree. Packet-mark ini digunakan untuk membedakan mana packet menuju ke server zoom, mana packet browsing biasa.

Untuk contoh konfigurasi pada simple queue adalah sebagai berikut :
 

Sedangkan contoh konfigurasi pada queue tree, harus menambahkan connection-mark dan packet-mark browsing terlebih dahulu.

Baru kita pisahkan berdasarkan packet-mark yang sudah dibuat, contoh adalah seperti berikut ini :


Konfigurasi ini bisa jadi solusi jika ingin koneksi menuju server zoom lebih prioritas tanpa ada gangguan. Jika ada client lain yang browsing, maka sudah dipisahkan bandwidthnya. Secara umum, saat video conference berlangsung aplikasi zoom akan menggunakan protocol UDP.  Dan bandwidth yang digunakan tergantung resolusi yang dipakai pada zoom meeting.
Memang informasi dari zoom untuk port yang digunakan pada protocol TCP dan UDP agak sedikit berbeda. Port yang digunakan pada TCP dan UDP dibuat sama untuk memudahkan konfigurasi.

Leave a Comment: